×

Application Downloads

All recent Geosoft Desktop installs are available for you to download.

Haven't found what you are looking for? Contact Support for previous versions or request a DVD.

What's in Geosoft 9.1.2

February 28, 2017
This update is for customers who have a current maintenance subscription and will update your software to Oasis montaj 9.1.2, Target 9.1.2, or Target for ArcGIS 9.1.2.
What's in Geosoft 9.1.2

Release Notes

About this Release

Oasis montaj 9.1.2 provides the following resolutions:

  • IS75612: Earth field magnitude values now reflect changes made to the displayed anomaly units, as expected.
  • IS192231: Abort no longer occurs: related to <CGeoMDIChildWnd::DestroyWindow>.
  • IS200344: GM-SYS Profile filtered anomaly (highpass and low pass) is no longer shifted relative to input profile data.
  • IS201005: Downloaded display images from Seeker are displaying automatically without error.
  • IS201178: Abort no longer occurs when using the 3D viewer: related to <RenderThreadMVIEW3D>.
  • IS202418: Abort no longer occurs when opening the Configure menu in GM-SYS Profile: related to <RunLasWellTableDialog>.
  • IS202425: Both the 2D vector drillholes and the new 3D drillholes now correctly plot the expected colours corresponding to the rock code file.
  • IS205370: Turning groups on and off in Map Manager no longer causes grids to be redrawn, irrespective of the number or size of grids.
  • IS205608: Error no longer occurs when using "Set Magnetic Elevation" in GM-SYS 2D: related to <System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam) >.
  • IS206544: Reduced likelihood of encountering "Pipe instances are busy" error related to Geosoft Connect, error when received does not impact program functionality in ArcMap.
  • IS207120: Abort no longer occurs when reconfiguring a GM-SYS 3D gravity survey.
  • IS207199: Permissions error no longer occurs when extracting a section from a voxel: related to <Geosoft.GX.GridUtils.PlotCrookedSectionGrid3D>.
  • IS207433: Colouring hole traces in 3D using string classified colours now honours the CSV colour file as expected.
  • IS207449: Able to now launch SEG-Y reader when using a Flex license, as expected.
  • IS207466: Able to load ArcGIS LYR files in OM when using a Flex license, as expected.

Target 9.1.2 provides the following resolutions:

  • IS192231: Abort no longer occurs: related to <CGeoMDIChildWnd::DestroyWindow>.
  • IS202425: Both the 2D vector drillholes and the new 3D drillholes now correctly plot the expected colours corresponding to the rock code file.
  • IS207433: Colouring hole traces in 3D using string classified colours now honours the CSV colour file as expected.

Target for ArcGIS 9.1.2 provides the following resolutions:

  • IS177559: Groups layers containing map layers are now being displayed individually and does not cause the progress bar to dead lock.
  • IS206544: Reduced likelihood of encountering "Pipe instances are busy" error related to Geosoft Connect, error when received does not impact program functionality in ArcMap.
  • IS207117: Error no longer occurs when opening ArcMap: related to <GeosoftConnLocalInstaller.exe>.

How to Update

You can update to this version either through the Help > Check for Updates option within your software or by downloading and installing the executable from the link top of this page.

The installation experience allows you to upgrade all of your maintained products as well as Geosoft's free software using a single executable.

System Requirements

Oasis montaj 9.1.2 and Target 9.1.2 have the same system requirements as Oasis montaj 9.1 and Target 9.1. A 64-bit version operating system of either Windows 10 (recommended), Windows 8.1, or Windows 7 SP1 is required. You will not be able to install on Windows XP or Windows Vista.

Target for ArcGIS 9.1.2 has the same system requirements as Target for ArcGIS 9.1. They are compatible with ArcGIS 10.4.1, 10.4, 10.3.1, 10.3, 10.2.2, or ArcGIS 10.2.1. Supported operating systems are either Windows 10 (recommended), Windows 8.1, or Windows 7 SP1. You will not be able to install on Windows XP or Windows Vista.

See detailed System Requirements.