×

Software Updates

All recent Geosoft Desktop installs are available for you to download.

Haven't found what you are looking for? Contact Support for previous versions or request a DVD.

What's in Geosoft 9.2.1

June 29, 2017
This update is for customers who have a current maintenance subscription and will update your software to Oasis montaj 9.2.1, Target 9.2.1, or Target for ArcGIS 9.2.1.
What's in Geosoft 9.2.1

About this Release

Oasis montaj 9.2.1 provides the following resolutions:

  • IS74894: Added the ability to plot more than 8 data sets to any section/plan map.
  • IS110763: Errors importing IP IRIS Instrument to Geosoft database no longer occur.
  • IS127765: Structural inversion now works on intervals that have variable densities above and below.
  • IS178279: Toggle Ruler and Toggle Snapping Grid now working when Base view is renamed.
  • IS200352: Named horizons no longer get corrupted or broken and can now be extracted from GM-SYS Profile models.
  • IS210043: Application abort no longer occurs when opening databases: related to the range of the string array channel in the database.
  • IS210771: Sections tools "Create Sections from Data" and "Multi-Parameter Sections from Data" are now honouring Extents.
  • IS211457: Using Grid Mosaic to merge multiple grids into one large grid now working.
  • IS211465: When importing multiple files with ASCII import, each file is imported as a new line.
  • IS212120: Error using UBC DCinv2D/IPinv2D file import no longer occurs.
  • IS212134: Oasis Montaj no longer crashes attempting to import a set of XYZ data with column array.
  • IS212455: Abort no longer occurs when attempting to export hole trace barplot data to a shapefile from a Section map: related to <Fill_VV>.
  • IS212457: Abort no longer occurs: related to <CGeoMFCToolBar::AdjustLocations>.
  • IS212459: Abort no longer occurs: related to <CCTL_Prof::OnClick>.
  • IS212924: Abort no longer occurs when attempting to use snapping to edit or create a Geostring for wireframing: related to <CEditSelect::sMarkPointedItems>.
  • IS213330: Map Manager remembers the last state of the folder/sub-folder tree before a map was saved.
  • IS213414: Abort no longer occurs: related to <CCTL_Prof::OnLButtonDown>.

Target 9.2.1 provides the following resolutions:

  • IS74894: Added the ability to plot more than 8 data sets to any section/plan map.
  • IS178279: Toggle Ruler and Toggle Snapping Grid now working when Base view is renamed.
  • IS210771: Sections tools "Create Sections from Data" and "Multi-Parameter Sections from Data" are now honouring Extents.
  • IS212134: Oasis Montaj no longer crashes attempting to import a set of XYZ data with column array.
  • IS212455: Abort no longer occurs when attempting to export hole trace barplot data to a shapefile from a Section map: related to <Fill_VV>.
  • IS212457: Abort no longer occurs: related to <CGeoMFCToolBar::AdjustLocations>.
  • IS212924: Abort no longer occurs when attempting to use snapping to edit or create a Geostring for wireframing: related to <CEditSelect::sMarkPointedItems>.
  • IS213330: Map Manager remembers the last state of the folder/sub-folder tree before a map was saved.
  • IS213414: Abort no longer occurs: related to <CCTL_Prof::OnLButtonDown>.

Target for ArcGIS 9.2.1 provides the following resolutions: <

  • IS74894: Added the ability to plot more than 8 data sets to any section/plan map.
  • IS211449: Wireframe bodies generated between polylines or polygons no longer extend outside the (manually defined) 3D Extents box.
  • IS213414: Abort no longer occurs: related to <CCTL_Prof::OnLButtonDown>.

How to Update

You can update to this version either through the Help > Check for Updates option within your software or by downloading and installing the executable from the link top of this page.

The installation experience allows you to upgrade all of your maintained products as well as Geosoft's free software using a single executable.

System Requirements

Oasis montaj 9.2.1 and Target 9.2.1 have the same system requirements as Oasis montaj 9.2 and Target 9.2. A 64-bit version operating system of either Windows 10 (recommended), Windows 8.1, or Windows 7 SP1 is required. You will not be able to install on Windows XP or Windows Vista.

Target for ArcGIS 9.2.1 has the same system requirements as Target for ArcGIS 9.1. They are compatible with ArcGIS 10.5, 10.4.1, 10.4, 10.3.1, or 10.3. Supported operating systems are either Windows 10 (recommended), Windows 8.1, or Windows 7 SP1. You will not be able to install on Windows XP or Windows Vista.

See detailed System Requirements.