×

Software Updates

All recent Geosoft Desktop installs are available for you to download.

Haven't found what you are looking for? Contact Support for previous versions or request a DVD.

What's in Geosoft 9.2.2

July 26, 2017
This update is for customers who have a current maintenance subscription and will update your software to Oasis montaj 9.2.2, Target 9.2.2, or Target for ArcGIS 9.2.2.
What's in Geosoft 9.2.2

About this Release

Oasis montaj 9.2.2 provides the following resolutions:

  • IS214504:Digitizing and snapping to a group under Geostring Features that does not exist in another map, now works as expected.
  • IS214303:Abort no longer occurs: related to <GDIXPD::sPolyLine>.
  • IS213666:All planned drillholes are preserved with refreshing and modifying the CSV used to create the Target project.
  • IS213662:Abort no longer occurs: related to <sPolygon_KML>.
  • IS212454:Dragging and Dropping a vector group from a 2D map into the 3D view now retains the line thickness, as expected.
  • IS212130:Abort exporting GDB to LAS no longer occurs: related to <sStableSort_VV>.

Target 9.2.2 provides the following resolutions:

  • IS214504:Digitizing and snapping to a group under Geostring Features that does not exist in another map, now works as expected.
  • IS214303:Abort no longer occurs: related to <GDIXPD::sPolyLine>.
  • IS213666:All planned drillholes are preserved with refreshing and modifying the CSV used to create the Target project.
  • IS213662:Abort no longer occurs: related to <sPolygon_KML>.
  • IS212454:Dragging and Dropping a vector group from a 2D map into the 3D view now retains the line thickness, as expected.
  • IS212130:Abort exporting GDB to LAS no longer occurs: related to <sStableSort_VV>.

Target for ArcGIS 9.2.2 provides the following resolutions:

  • IS213666:All planned drillholes are preserved with refreshing and modifying the CSV used to create the Target project.
  • IS212130:Abort exporting GDB to LAS no longer occurs: related to <sStableSort_VV>.

How to Update

You can update to this version either through the Help > Check for Updates option within your software or by downloading and installing the executable from the link top of this page.

The installation experience allows you to upgrade all of your maintained products as well as Geosoft's free software using a single executable.

System Requirements

Oasis montaj 9.2.2 and Target 9.2.2 have the same system requirements as Oasis montaj 9.2 and Target 9.2. A 64-bit version operating system of either Windows 10 (recommended), Windows 8.1, or Windows 7 SP1 is required. You will not be able to install on Windows XP or Windows Vista.

Target for ArcGIS 9.2.2 has the same system requirements as Target for ArcGIS 9.2. They are compatible with ArcGIS 10.5, 10.4.1, 10.4, 10.3.1, or 10.3. Supported operating systems are either Windows 10 (recommended), Windows 8.1, or Windows 7 SP1. You will not be able to install on Windows XP or Windows Vista.

See detailed System Requirements.