×

Software Updates

All recent Geosoft Desktop installs are available for you to download.

Haven't found what you are looking for? Contact Support for previous versions or request a DVD.

What's in Geosoft 9.4.1 SP1

June 28, 2018
This update is for customers who have a current maintenance subscription and will update your software to Oasis montaj 9.4.1 SP1, Target 9.4.1 SP1, or Target for ArcGIS 9.4.1 SP1.

About this Release

Oasis montaj 9.4.1 SP1 provides the following resolutions:

  • IS220287 : An abort <bGetFromSharedFile> which may occur when launching Oasis montaj, has been resolved in the Compiler.

Target 9.4.1 SP1 provides the following resolutions:

  • IS220287 : An abort <bGetFromSharedFile> which may occur when launching Target, has been resolved in the Compiler.

Target for ArcGIS 9.4.1 SP1 provides the following resolutions:

  • IS220287 : An abort <bGetFromSharedFile> which may occur when launching Target for ArcGIS, has been resolved in the Compiler.

How to Update

You can update to this version either through the Help > Check for Updates option within your software or by downloading and installing the executable from the link top of this page.

The installation experience allows you to upgrade all of your maintained products as well as Geosoft's free software using a single executable.

System Requirements

Oasis montaj 9.4.1 SP1 and Target 9.4.1 SP1 have the same system requirements as Oasis montaj 9.4 and Target 9.4. A 64-bit version operating system of either Windows 10 (recommended), Windows 8.1, or Windows 7 SP1 is required. You will not be able to install on Windows XP or Windows Vista.

Target for ArcGIS 9.4.1 SP1 has the same system requirements as Target for ArcGIS 9.4. They are compatible with ArcGIS 10.6, 10.5.1, 10.5, 10.4.1, 10.4, 10.3.1, or 10.3. Supported operating systems are either Windows 10 (recommended), Windows 8.1, or Windows 7 SP1. You will not be able to install on Windows XP or Windows Vista.

See detailed System Requirements.